0

We have a n older site that was created in MOSS 2007 with an internal URL (default zone having windows auth) and then was extended to use FBA with an external URL. The site was converted to 2013 a few months ago.

Users use the external URL to access the site. It was found that when they signed up for an alert the URL in the alert was using the internal URL which of course they could not access.

The external URL was then set as the default zone and the internal URL was set as the internet zone so that the proper URL would be used in the links for the alerts.

However the content source for this site is set using the internal URL. Around the same time the site search stopped working. We're thinking this could be the cause.

If it is, this site can't be the only one set up this way. Is there a way to have the alerts working with the correct external URL and having the search working as well?

0

What you are seeing is expected behavior. Both

  • Alerts using the default zone url
  • Search also need Default zone with Windows Authentication.

Now you can try the below solution which help us to save our lives. There is an option in SharePoint called Configure a cross-firewall access zone you have to configure it, once done now external zone user will get the alerts with correct url. it is workaround.

  • Verify that you have the following administrative credentials: You must be a member of the Farm Administrators group.
  • In Central Administration, click System Settings.
  • On the System Settings page, under Farm Management, click Configure cross firewall access zone.
  • On the Cross Firewall Access Zone page, in Web Application , in the Web Application list, select the web application that is published across the firewall.
  • In Cross Firewall Access Zone, in the Zone selection for cross firewall access list, select the zone that is published across the firewall.

Read complete article on this link

  • We were going configure the as suggested and were preparing to modify our dev environment to more closely match production in order to test this out when the client reported that the search is now working. Looking into this further it was discovered that the server was rebooted over the weekend which may have fixed the issue. However, everything I've read indicates the search shouldn't be working but it is. – rsford31 Nov 2 '16 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.