1

I've assigned users to the "Health and Safety" group and the group has permissions set to it. I now want to assign the group access to the "Health and Safety" subsite that sits directly underneath the site collection. How do I do this? I can't see the option on site permissions. See screen shot.

enter image description here

We're using sharepoint online.

Thanks

3

You have to go to the subsite, click the Gear to go to Site Settings and then click Site Permissions. From there, you can add your group by clicking the Grant Permissions button. If you do not see these options, then you don't have the rights to do so in the subsite.

If the subsite is inheriting permissions from the parent, then by adding them to the site collection root, they automatically have permission in the subsite.

  • 1
    Thanks for your answer :-) I've added a picture to the original post of the site permissions page. I can create group but not add the group to the sub site. What am i missing? I'm the site collection administrator. Thanks – resolver101 Oct 27 '16 at 13:51
  • Assuming that is the screenshot of the Health and Safety subsite, simply click grant Permissions and add your group with the desired permissions. – Eric Alexander Oct 27 '16 at 13:55
  • Yes its the Health and Safety subsite. I've clicked grant permissions and added the user in the invite people. Clicked "show options" and I can't see the group i've added. I would have expected to be able to add the group, any ideas why i cant? – resolver101 Oct 27 '16 at 14:46
  • Because the group doesn't have permission in the subsite so it doesn't allow you to add users in this way. Click Grant permissions and add the "Health and Safety" group and grant them the desired permission. – Eric Alexander Oct 27 '16 at 15:18
  • Sorry im probably missing something really simple here. If I add "Health and Safety Group" it says "sharing failed: sharepoint groups cannot contain other sharepoint groups. Remove the sharepoint group from the users box and try again." – resolver101 Oct 27 '16 at 15:39
1

I've run into the same situation and it's because the "Inherit Permissions" setting is ON (this is the default setting) for your subsite. If you want Inherit Permissions on so that all groups in the Parent site also have access to the subsite, then you have to add the "Health and Safety" SharePoint group to the Parent site first. Then you can add it to your subsite. Otherwise, you have to turn off Inherit Permissions to add the "Health and Safety" group only to your subsite.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.