1

I've manually created a Composed Look and have a problem that the Composed Look is not inherited to all subwebs.

If publishing is activated the Composed Look is inherited.

But for some sites that don't have it active the Composed Look is inherited and for some its not.

Does anyone know where/if there is a setting to "inherit Composed look from parent".

EDIT: Problem solved

Follow these steps:

  1. Activate Publishing Infrastructure Site Feature
  2. Go to: /_layouts/15/ChangeSiteMasterPage.aspx
  3. Reset inheritance for subwebs
  4. "OK"
  • 1
    But, what if we don't want to activate Publishing Infrastructure site feature ? AKA : the publishing infrastructure site feature do not allow to use anything from site templates.... – Gaelle Oct 26 '16 at 12:12
  • @Gaelle It looks like we have to do a manual job for all webs :( but if you find another way please add it as an answer! – George Norberg Oct 26 '16 at 12:24
1

In SharePoint online this functionality is moved to the master page settings page (Site Settings > Master Page) under the Theme section of that page. Check screenshot

enter image description here

You can also use the below powershell to push the update:

$url = "http://your-site"
$site = Get-SPSite -Identity $url
Write-Host "RootWeb Theme: " site.RootWeb.ThemedCssFolderUrl

foreach ($web in $site.AllWebs) {
  Write-Host "Web Title: " $web.Title
  Write-Host "Web Theme: " $web.ThemedCssFolderUrl

  $web.ThemedCssFolderUrl = $site.RootWeb.ThemedCssFolderUrl
  $web.Update()

  $web.Dispose()
}

$site.Dispose();
  • Thanks for the link but the link is related to SharePoint 2013 and not SharePoint Online. I can't find the page with that setting in onprem or online. – George Norberg Oct 26 '16 at 10:56
  • 1
    You need to enable the SharePoint Server publishing feature from site collection features and SharePoint publishing feature from the web features. Else, go to the sitecollectionurl//_layouts/15/ChangeSiteMasterPage.aspx, there you will find this. – Gautam Sheth Oct 26 '16 at 11:00
  • 1
    check the changed image. I am using SharePoint online only. – Gautam Sheth Oct 26 '16 at 11:03
  • Thanks for the link, strange thing is that when i go on the URL it works. But I could not find it in the site settings!? – George Norberg Oct 26 '16 at 11:04
  • 1
    hmmm, as mentioned above you need to enable both features, SharePoint Server publishing infrastructure at site collection and SharePoint Server Publishing at the site level for this link to be visible. – Gautam Sheth Oct 26 '16 at 11:05
2

https://www.eliostruyf.com/sub-site-themecomposed-looks-inheritance-how-to/

In SharePoint 2013 this functionality is moved to the master page settings page (Site Settings > Master Page) under the Theme section of that page.

But what with non-publishing sites? These sites do not have this functionality. Unfortunately, the only way to set up theme inheritance is via code.

See the link above to see the code the guy built

  • Hello @susan, I do have tried to check the "inherit from parent's masterpage" and "inherit from parent's theme" checkboxes on this settings page, but it does nothing. FIY, if you want to access the Look > Masterpage setting page, you can add /_layouts/15/ChangeSiteMasterpage.aspx to your site url. This page is hidden, but it works well even for non-publishing sites. – Gaelle Oct 26 '16 at 12:09
  • It seems that accessing the ChangeSiteMaster.aspx page via direct URL works for SP2013 but in SP2016 it just shows up as a blank page unless the PI feature is enabled. It seems crazy that we need to run code to do this. I'll see if I can develop a UI extension – Colin Gardner Mar 16 '17 at 23:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.