1

I tried creating a Sharepoint-hosted app with workflow using Sharepoint 2013 and Visual studio 2015 CE(also tried VS 2013 CE) as in this MSDN tutorial. When I tried to deploy, it failed with the following error message

Error Message.

@"Error 1
CorrelationId: 15bc3687-1651-4998-a950-62604875a927
ErrorDetail: There was an error during the operation.
ErrorType: Configuration
ErrorTypeName: Configuration
ExceptionMessage: Object reference not set to an instance of an object.
Source: Common
SourceName: Common App Deployment Error occurred in deployment step 'Install SharePoint Add-in': Failed to install SharePoint Add-in. Please see the output window for details.

I also tried creating a very simple workflow by just terminating the workflow. Again the same problem.

If I publish the app(*.app) package, am unable to add it to the team site. All it says is
Sorry, This app is not supported on your server ScreenShot

I tried following workarounds for this as pointed by some blogs,

  1. Changing the AppPreRequisite Id to 'B1DDD88F-6ADD-4700-B5CD-18E451635E24' in Appmanifest.xml file. * - [Not working. Same problem]*.
  2. Deleting the AppPreRequisite section in Appmanifest.xml file.
    On deleting this section it stopped saying unsupported app message and I can able to click on ADD IT button. But the app gets failed to add in the site.
  3. Updated Workflow manager to CU2. -[Same problem]

    Extra Information : Workflow manager is working fine because if I add workflow to a webpart using Sharepoint designer it works fine.

This is killing me for more than 3 weeks.
Any help would be greatly appreciated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.