0

I get below errors when I run the SharePoint 2016 configuration wizard in single server deployment and sql server also inside same server this is development environment

Resource id to be retrieved is PostSetupConfigurationFailedEventLog for language English (United States) 10/24/2016 10:37:38 12 INF Resource retrieved id PostSetupConfigurationFailedEventLog is Configuration of SharePoint Products failed.

Entering function TaskDriver.OnTaskDriverStop 10/24/2016 10:37:38 12 INF Sending a task driver stop event: TaskDriverEventArgs.EventCriticalityType error, TaskDriverEventArgs.EventType.stop,

enter image description here

UPDATE

Appfaric cache service still in problem.

Error while installing AppFabric:

AppFabric 1.1 for Windows Server -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action Env_PSModulePath_powershell_i, location: c:\Program Files\AppFabric 1.1 for Windows Server\Microsoft.ApplicationServer.InstallHelper.exe, command: powershell.exe "-command \"$str = [System.Environment]::GetEnvironmentVariable(\\"PSModulePath\\", [System.EnvironmentVariableTarget]::Machine); $str = $str+\\";c:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules\\"; c:\Windows\system32\setx.exe /M PSModulePath \\"$str\\"\"" "C:\Users\spinstall\AppData\Local\Temp\AppServerSetup1_1_CustomActions(2016-10-24 20-03-00).log"

1

Try below steps:

1. Repair distributed cache

Tried to repair distributed cache on the server by executing the following line of PowerShell script

Get-SPServiceInstance
$s = Get-SPServiceInstance <<Distributed Cache GUID>>
$s.delete()
Add-SPDistributedCacheServiceInstance

For some reasons, the script throws following error on line Add-SPDistributedCacheServiceInstance

Add-SPDistributedCacheServiceInstance : Could not load file or assemblly 'Microsoft. ApplicationServer.Caching.Configuration, Version=1.0.0.0, culture=neutral, PublicKeyToken=31bf3856ad364e35'or one of its dependencies. The system cannot find the file specified.

enter image description here

2. Start AppFabric Caching Service

Started AppFabric Caching Service and add the SPDistributedCacheServiceInstance enter image description here

3. Install CU7 for AppFabric 1.1

Since running the configuration wizard again failed, downloaded and Installed Cumulative Update 7 (KB3092423) for Microsoft AppFabric 1.1 for Windows Server

NOTE: If you get error in installation of AppFabric then check for PSModulePath environment variable value. It may contain " at the end of the value. Please remove the " from the end and try to install it again.

https://support.microsoft.com/en-in/kb/3092423

4. Reboot

Restart the computer after applying this cumulative update package.

5. PS Script

After successfully installing the CU package. Execute the following PowerShell script to remove the caching service instance.

$SPFarm = Get-SPFarm
 $cacheClusterName = "SPDistributedCacheCluster_" + $SPFarm.Id.ToString()
 $cacheClusterManager = [Microsoft.SharePoint.DistributedCaching.Utilities.SPDistributedCacheClusterInfoManager]::Local
 $cacheClusterInfo = $cacheClusterManager.GetSPDistributedCacheClusterInfo($cacheClusterName);
 $instanceName ="SPDistributedCacheService Name=AppFabricCachingService"
 $serviceInstance = Get-SPServiceInstance | ? {($_.Service.Tostring()) -eq $instanceName -and ($_.Server.Name) -eq $env:computername}
 $serviceInstance.Delete()

enter image description here

6. Run the Configuration Wizard again

The configuration should be successful.

Reference:

  • Hi when did step 2 i did not found AppFabric Caching Service in services.msc? please help – adilahmed Oct 24 '16 at 10:46
  • If your SharePoint prerequisites are installed properly, then you can see this service. Please check for SharePoint prerequisites installation before installing SharePoint. – Dikesh Gandhi Oct 24 '16 at 10:59
  • i enable internet in this server and installed prerequisites and now can i uninstall sharepoint and install again? – adilahmed Oct 24 '16 at 11:10
  • You can uninstall SharePoint from Start Menu -> Control Panel -> uninstall a program. – Dikesh Gandhi Oct 24 '16 at 11:18
  • same issue after i uninstall and install and i did not found app fabric service in services list – adilahmed Oct 24 '16 at 13:05
0

after i remove " from PSModulePath environment variable and Repair distributed cache it works for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.