1

I am trying since multiple days installing SharePoint 2013 Foundation farm (no standalone development environment), but the Configuration Wizard stucks doggedly at step 9 of 10. Now I am at the end of my wisdom and my nerves.

Please help me with a solution for this issue. Thank you very much in advance.

My environment is as follows:

  • Windows 2008 R2 Enterprise with IIS version 7.0 (is this IIS version correct?)
  • SQL Server Express 2008 R2 ADV (ADV = Advanced Services)
  • SharePoint 2013 Foundation with Service Pack 1 and really all possible updates
  • My virus protector is off
  • My firewall is off

The Error (in German)

Wizard error message at step 9 of 10

in brief:

Microsoft.SharePoint.Upgrade.SPUpgradeException: Action 4.0.3.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed

The log file says:

Task upgrade has failed with an unknown exception Exception: Microsoft.SharePoint.Upgrade.SPUpgradeException: Action 4.0.3.0 of Microsoft.SharePoint.Upgrade.SPIisWebSiteWssSequence failed. ---> System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt. bei Microsoft.SharePoint.Administration.SPAspSiteMapFile.MergeAspSiteMapFiles(XmlDocument xmldocSiteMap, String strSrcFilePath, String strMergeFilePattern)
bei Microsoft.SharePoint.Administration.SPAspSiteMapFile.Copy(String strSrcDir, String strSrcDirPrevious, String strSrcLeaf, String strDestDir, Boolean bMergeMaps, Boolean bBackupExistingFile) bei Microsoft.SharePoint.Administration.SPWebApplication.CopyAppDomainDirectories(DirectoryInfo vrPath, OverwriteSetting overwrite) bei Microsoft.SharePoint.Upgrade.SPActionSequence.Upgrade() --- Ende der internen Ausnahmestapelüberwachung ---

I tried:

  • Deleting cache files and editing cache.ini
  • Starting configuration wizard from command line:
  • stsadm -o execadmsvcjobs
  • PSConfig.exe -cmd upgrade -inplace b2b -force
  • Removing SharePoint and SQL Server and re-install them again

and much more from a hundred of Google findings

BUT NOTHING WORKS! Please help me with a solution for this issue. Thank you very much in advance.

  • This link may help you. : xpertkb.com/… – Dikesh Gandhi Oct 23 '16 at 12:52
  • There are numerous way to start the troubleshooting, and to try the possible fixes. Did you give a shot for Get-SPProduct -local as well before running the Configuration Wizard? You could also start the possibly non-running timer jobs by Start-SPAdminJob -Verbose. – moe Oct 24 '16 at 7:41
  • I tried the two PS commands and finally it dit not solve the problem, but I could see in the Task Manager that the services SPTimerV4 and as well SPAdminV4 are ended. I tried starting them manually but after some seconds they became ended again! Regarding the link: I am not able to start the Central Administration and therefore I can not follow the instructions. – Ernst Lehmann Oct 29 '16 at 17:06
  • Finally I reformatted my harddisk and reinstalled Windows Server 2008 R2, SQL-Server 2008 and SharePoint 2013. Now it works. – Ernst Lehmann Nov 26 '16 at 22:10
0

I was dealing with the same issue, turns out I was missing the web.config file in the virtual directory, which seemed unlikely but sure enough there was no web.config file there, I had to copy it from my other WFE and then we were good to go

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.