0

Here the scenario; 2 wfe servers named: spwfe01, spwfe02 and 2 application servers named: spapp01, spapp02. internal domain name contoso.local so the servers names are spwfe01.contoso.local etc. Our internet domain is contoso.com. Our users, access the portal with portal.consotoso.com . So the what is the best practice with AAM configuration.

Here is the ip addresses

portal.contoso.com  192.168.1.50 (Load Balancer)
spwfe01             192.168.1.31
spwfe02             192.168.1.32
spapp01             192.168.1.21
spapp02             192.168.1.22

Internal URL                    Zone        Public URL for Zone
------------                    ----        -------------------
http://portal.contoso.com       Default     https://portal.contoso.com
https://portal.contoso.com      Default     https://portal.contoso.com
http://spwfe01                  Default     https://portal.contoso.com
http://spwfe02                  Default     https://portal.contoso.com
http://spapp01                  Default     https://portal.contoso.com
http://spapp02                  Default     https://portal.contoso.com

In the DNS Server, servers have the correct records.

For loopbackcheck issue i added hosts files 127.0.0.1 for portal.contoso.com (every server in the farm) and configured the registry via https://blog.blksthl.com/2013/05/07/a-quick-guide-to-configuring-the-loopback-check/ .

But last days i have expreienced weird issue with the WAC server. WAC server gives error like "Sorry, there was a problem and we can't open this document. If this happens again, try opening the document in Microsoft Word." In the ULS logs: "System.IO.FileNotFoundException: The system cannot find the file specified" After digging google for hours i found the solution. In the WAC server's hosts files i added this row: 192.168.1.31 portal.contoso.com (spwfe01's ip address)

Where did i wrong about aam conf.

0

My suggestion is to use 127.0.0.1 only to DEV proposes in a laptop, desktop. This will help you to develop even not connected to the internet. The AAM is referenced in the database although is in the pipeline also, so you have to use the URL himself. If you access via IP you will get errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.