2

I'm developing an InfoPath 2010 form containing C# code. On my virtual machine I have a SharePoint 2010 standalone installation. When I started developing the form, I generated a certificate in the InfoPath Designer client for testing and everything worked.

When this certificate expired (valid 1 month) the Designer offered to remove it from the form, I agreed. Then I went to the settings and let Designer create a new certificate. I published the form (still in/to the development vm).

Ever since then the form doesn't work. The InfoPath Filler declines the certificate with the error "Infopath cannot load this form. Either the signature is corrupted, or the certificate used to sign this form is expired or revoked."

I tried so far to:

  • generate a new cerficate
  • install the certificate to Personal and Trusted Root Certification Authorities store
  • delete the Forms\template.xsn and publish again
4

Try clearing infopath cache. I had exactly the same problem and did everything you listed above. Start > Run > Infopath /cache clearall

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.