0

I am getting following error for Get-SPSite with no site collection name. Any ideas on what would cause this error to showup.

Get-SPSite : The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If us ing a custom encoder, be sure that the IsContentTypeSupported method is impleme nted properly. The first 1024 bytes of the response were:

XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-st rict.dtd"> IIS 7.5 Detailed Error - 500.19 - Internal Server Error style type="text/css"> comment symbol body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;bac kground:#CBE1EF;} code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;} .config_source code{font-size:.8em;color:#000000;} pre{margin:0;font-size:1.4em;word-wrap:break-word;} ul,ol{margin:10px 0 10px 40px;} ul.first,ol.first{margin-top:5px;} fieldset{padding:0 15px 10px 15px;} .summary-container fieldset{padding-bottom:5px;margin-top:4px;} legend.no-expand-all{padding:2px 15px 4px 10px;margin:0 0 0 -12px;} legend{color:#333333;padding:4px 15px 4px 10px;margin:4px 0 8px -12px;_margin-t op:0px; border-top:1px solid #EDEDED;border-left:1px solid #EDEDED;border-right:1px so lid #969696; border-bottom:1px solid #969696;background:#E7ECF0;font-weight:bold;'. At line:1 char:11 + get-spsite <<<< + CategoryInfo : InvalidData: (Microsoft.Share...SPCmdletGetSite: SPCmdletGetSite) [Get-SPSite], ProtocolException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGetSite

0

this error leads me towards the web.config discrepancy.

Please check the Web.config files for the Web application ( which u are trying to run the get-spsite) is correct, also check the Central admin web.config file.

You can also try to run the get0spwebapplication and see if that return any result.

  • Get-SpWebApplication webappURL returns the web application. When I try webapp.Sites, It gives the same error – Nate Oct 23 '16 at 21:04
  • I tried for all the web applications to get there sites, but I get above error for all webapplications – Nate Oct 23 '16 at 21:18
  • when I try , get-spsite siteUrl, I get following error "get-spsite : Cannot find an SPSite object with Id or Url: siteUrl. At line:1 char:9 + $site = get-spsite("siteUrl") + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidData: (Microsoft.Share...SPCmdletGetSite: SPCmdletGetSite) [Get-SPSite], SPCmdletPipeBindException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGetSite – Nate Nov 8 '16 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.