2

enter image description hereI have created a custom page layout using module and .aspx page.

I have uploaded it in the _catalog/masterpage folder. It gets uploaded in the folder, but I want to set that custom page layout in my application as default.

How to do that?

2
  • Do you want the created layout will be appear in the list of layouts seen while creating the new page?
    – Ram
    Oct 20, 2016 at 12:01
  • Ya.. I want to select my custom page layout when creating a page
    – Madhu
    Oct 20, 2016 at 13:04

2 Answers 2

1
  • You have to Publish your Page Layout then you can see the page layout in the drop-down list.
  • Just edit your page layout in the browser and set proper name and then publish it.
  • Once you have published this page-layout, You can see your page layout while creating a new page.
  • Hope this will help you.
4
  • Already Its published but the custom page layout is not displayed. I will attach screenshot in my question
    – Madhu
    Oct 20, 2016 at 13:28
  • Screen shot does not explain anything.
    – Ram
    Oct 20, 2016 at 13:37
  • I have published the page layout but that custom page layout doesn't displayed in the list which you mentioned in eVT answer
    – Madhu
    Oct 20, 2016 at 14:21
  • Did you find the answer? if yes then post as answer.
    – Ram
    Oct 26, 2016 at 19:10
0
YOURWEB/_layouts/15/AreaTemplateSettings.aspx

Under Page Layouts add your New Page Layout

Under New Page Default Settings check your new Page Layout

enter image description here

----edit

try this

YOURWEB/_catalogs/masterpage/Forms/AllItems.aspx

Find your new Page Layout and click edit properties

Under Associated Content Type check your Content Type (If is _Hidden you will not view that page layout under settings)

2
  • In that list I didn't see my custom page layout.. Actually it get uploaded in _catalog/masterpage folder
    – Madhu
    Oct 20, 2016 at 13:11
  • check edited answer
    – Marko Tica
    Oct 20, 2016 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.