1

We have shared some folders in our document library to external client and are available for them. But i am not sure how to enable the open with explorer options to them.

Please advise.

7
  • Do they use Internet Explorer 32-bit version and are members of the site?
    – Benny Skogberg
    Oct 20, 2016 at 8:03
  • "Limited-access user permission lockdown mode" - deactivate this feature from site collection features Oct 20, 2016 at 8:08
  • what does it do ? .The option is available for us. only to the external clients who is not in our domain has this problem
    – Rinu
    Oct 20, 2016 at 8:17
  • yes IE is 32 bit
    – Rinu
    Oct 20, 2016 at 8:17
  • support.microsoft.com/en-in/kb/3039997 When you share a folder with a user who can't access the parent folder or site, SharePoint assigns the user limited access to the parent items. Specifically, SharePoint lets the user access the folder without obtaining permission to access the parent folder and other items (other than limited access). However, after Limited-access user permission lockdown mode is enabled, the user doesn't have access to the folder because the necessary limited access permission on other items no longer works correctly. Oct 20, 2016 at 8:29

1 Answer 1

2

You need to deactivate the "Limited-access user permission lock down mode" feature from the site collection.

Because this feature is activated by default, from Users can't access a shared folder in SharePoint Online following happens:

When you share a folder with a user who can't access the parent folder or site, SharePoint assigns the user limited access to the parent items. Specifically, SharePoint lets the user access the folder without obtaining permission to access the parent folder and other items (other than limited access). However, after Limited-access user permission lockdown mode is enabled, the user doesn't have access to the folder because the necessary limited access permission on other items no longer works correctly.

Also, this kinda disables the open in explorer feature for users with limited access permission.

From Enable or disable site collection features

enter image description here

Edit-

You can try a couple of options as mentioned below:

1) Sign in to the SharePoint Online site by using your Office 365 work or school account credentials. When you do this, make sure that you select the Keep me signed in check box

2) Add the SharePoint online site to trusted sites.

You can try and follow this troubleshooting guide - How to use the "Open with Explorer" command to troubleshoot issues in SharePoint Online

1
  • HI Gautham, this feature is not activated in the site collection level, still having problems to share folders to the third party
    – Rinu
    Oct 23, 2016 at 4:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.