2

I have a SharePoint 2010 workflow set to run on item creation & change. While this workflow runs good for 90% of the time, at items it "Fails on start(retrying)". The error in Workflow history list would be "The workflow could not update the item, possibly because one or more columns for the item require a different type of information". For the same list item, it runs fine if the error instance is terminated and the workflow is restarted.

To debug I added "Log to workflow list" as 1st line of the workflow and after every action. But whenever the workflow fails, the log at 1st line doesn't get added to history list.

Does this mean the workflow fails during logging?

There are no errors if a pause is added at first. But the paused instance will restart after 5 mins only. This is unacceptable from business.

What could be the possible reason for the failure? Is there anyway I could loop within the workflow for 5-10 seconds, since a few sec pause seems to fix this?

Experts help please.

UPDATE: This workflow usually start while some other workflow makes change to the list item.

  • Please update question by adding workflow screen shots – Akshay Dattatray Nangare Oct 18 '16 at 11:21
  • 1
    You might check the ULS Logs in the time the workflow failed. (Maybe check here: technet.microsoft.com/en-us/library/fp161379.aspx) – Patrick Oct 18 '16 at 11:22
  • @Patrick great stuff, wrote silly comment reply and then read the link and yay for SPO PowerShell commands, will be really useful! This comment could be potentially turned into a good answer if you deliberate a bit more. – Cthulhubutt Oct 18 '16 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.