Our Sharepoint Portal Server 2003 home page has three data view web parts that display different lists. Starting Saturday, all three web parts starting returning this error:

Unable to display this Web Part. To troubleshoot the problem, open this Web page in a Windows SharePoint Services-compatible HTML editor such as FrontPage. If the problem persists, contact your Web server administrator.

To our knowledge very little has changed on the site recently (no patches installed, edits, etc) - the problem happens to everyone (regardless of account/permissions). The strange thing is that we installed an old version of frontpage and opened the sharepoint site - all the web parts display properly inside frontpage (with live/valid data) when editing the home page.

I've confirmed that the web part's list guid matches that of the actual list and have removed any unneeded fields from the datasource - but the problem still persists. Any help or advice is appreciated. Thanks

2 Answers 2


Thanks for everyone's answers. After banging my head against the wall for many hours - in the end we traced this back to the latest patch for SharePoint Services 2.0 (KB2494007).

To summarize - on 9/17/2011, all DataView web parts on our website that display data from lists were no longer working. The DataView web parts instead displayed the "Unable to display this Web Part" error. This appears to be a known issue with the latest patch for SharePoint Services 2.0 (KB2494007) that was published on 9/12/2011 and installed on our servers on 9/17/2011. Microsoft has acknowledged the bug and is working on a fix - though no ETA for the fix has been set yet.

I have been unable to find a good workaround at this time using a DataView web part and it's flexible data formatting tools. The closest work around I have found is to use a ListView web part to display the data. It appears that the only known fix at this time is to roll back the server to a restore point before patch KB2494007 was applied.


I assume you have tried the obvious: iisreset and/or reboot the server?

  • Thanks for your answer. Unfortunately yes - I tried a full iisreset and bouncing the app pools individually but it didn't seem to make a difference
    – jskunkle
    Sep 20, 2011 at 12:51
  • What about a complete reboot? Are you sure that windows update didn't run recently or anything on the servers? Also, have you thought a spinning up a VM or something and adding it to the farm to see if it has the same problem or not? Sep 20, 2011 at 13:29
  • Hello Steve - Thanks again for your help. I just talked to the network guys and they did reboot both the web and db servers after the problem showed up - but unfortunately it didn't make a difference. I will look into adding a new vm/webserver - but I'm not sure we will be able to get that online quickly with our setup
    – jskunkle
    Sep 20, 2011 at 14:44
  • Could this be a loopback problem? harbar.net/archive/2009/07/02/… Sep 20, 2011 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.