1

We have SharePoint 2013 Enterprise and a MS Office 2010 and IE 11. In addition the library in question I have set to open in client.

I and others can click on an xlsx spreadsheet link from within a Document library and am prompted with a "Open" dialog box which has the options of "Read" or "Edit". When we click on Edit we have no issues editing the spreadsheet.

Others however click on the same xlsx spreadsheet (or any spreadsheet within the Document library) from within the Document library and rather than get the "Open" dialog box, a message at the bottom of the screen displays that the file has been downloaded and asking if the file should be opened. For this subset of users if the file is opened they then get prompted at the top of the spreadsheet (within Excel) if they would like to edit the server file copy. When they click on "edit file" they get the error message: The file or folder name document_url/document_name.xlsx?NoRedirect=true contains characters that are not permitted. Enter a different name

Why do the users in scenario 2 not get the "Open" dialog box and instead the file downloads ? Why do users in scenario 2 not able to edit the spreadsheet ?

Note I have cleared the cache, etc.

  • Are all the users have same IE version with you? Have all of you placed the sharepoint site into trusted? Also are the xlsx filename in English? – Mark L Oct 18 '16 at 0:58
  • 1-I need to check that all have the same IE versions, but I assume all are the same version. 2-Do I need to check within IE if it is a trusted site ? If yes then I doubt any if us have it as Trusted Site as this option is locked down for us in IE 3-The xlsx filename is in English – daPlayaURH Oct 18 '16 at 3:15
1

You need to check if it is a trusted site in IE and secondly check if both group of users have the same permissions.

  • We don't have access to change the Trusted sites so my assumption is that Trusted Sites configuration is the same as mine...Also the permissions are the same as mine.. – daPlayaURH Oct 19 '16 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.