I have mapped the "Mobile Number" property to Active Direcotry and want to display the "mobile number" field on the "editprofile.aspx" page without allowing the user to edit the property. It is not being displayed if I make field to "do not allow the user to edit the property". What could be the issue? and fix?

2 Answers 2


Browse to the User Profile service application and select the manage user properties link. From here, find the mobile number field and select the edit item from the item context menu.

Once in there, scroll down to the Display Settings section and check the "Show on the Edit Details page" option.

You may also want to check the "Show in the profile properties section of the user's profile page" option.

If you have not already done so, you will want to map the property for import since it will not automatically map to all fields in AD, only a set of predefined fields. You can define the mapping at the bottom of the page.

Click OK when you are finished to save the changes.


Just add the field with out any properties (like read only, hidden). Then make sure it shows up in editform. Then open SharePoint Manager (not designer) and navigate to the field and make the field read only.


  • Created a test property and allowed users to edit the property, It was displayed on the editprofile.aspx page. Went to UPA and disabled the "Allow users to edit this property" option, the property disappears from the editprofile.aspx page...any clue? What do you mean by SharePoint Manager, are you referring CA? Commented Sep 19, 2011 at 13:50
  • I am referring to SharePoint Manager. I had a situation where I needed to disable edit on certain fields. You can also create feature based (xml) solution and implement edit=false in xml file. Commented Sep 19, 2011 at 14:20
  • 1
    SharePoint Manager is a great and powerfull tool from codeplex.com. spm.codeplex.com but handle with care... this can screw up your site pretty bad ;-) Commented Sep 19, 2011 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.