1

I'm using the calendar app in SharePoint.

I add a custom person/group field. Autocomplete doesn't work by default. So, i created a new custom form.

In this custom form, I changed SharePoint:FormField to SharePoint:ClientPeoplePicker.

Now, autocomplete works correctly.

But my problem is, when I save the form, the value of my person field is not saved.

Does anyone know why ?

EDIT:

I created a NewForm in SPD2013, i'm calling it "test.aspx"

I open it, and I retrieve my field name "pop" .

<tr>
  <td width="190px" valign="top" class="ms-formlabel">
    <H3 class="ms-standardheader">
        <nobr>pop</nobr>
    </H3>
  </td>
  <td width="400px" valign="top" class="ms-formbody">
    <SharePoint:FormField runat="server" id="ff9{$Pos}" ControlMode="New" FieldName="pop" __designer:bind="{ddwrt:DataBind('i',concat('ff9',$Pos),'Value','ValueChanged','ID',ddwrt:EscapeDelims(string(@ID)),'@pop')}"/>
    <SharePoint:FieldDescription runat="server" id="ff9description{$Pos}" FieldName="pop" ControlMode="New"/>
  </td>
</tr>

I'm changing SharePoint:FormField to SharePoint:ClientPeoplePicker like that:

<SharePoint:ClientPeoplePicker runat="server" id="ff9{$Pos}" ControlMode="New" FieldName="pop" __designer:bind="{ddwrt:DataBind('i',concat('ff9',$Pos),'Value','ValueChanged','ID',ddwrt:EscapeDelims(string(@ID)),'@pop')}"/>
<SharePoint:FieldDescription runat="server" id="ff9description{$Pos}" FieldName="pop" ControlMode="New"/>
  • Please add more details like what code model you are using? Also add your code section. – Trimantra Software Solution Oct 11 '16 at 11:06
  • I added all my step . – EGuidez Oct 11 '16 at 11:56
  • I have the same issue looks like this is a bug from Microsoft – santosh kondapalli Sep 14 '17 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.