2

I am following below URL to configure Search Service Application in Sharepoint 2013 farm(2 APPS and 2 WFE).When i run "Set-SPEnterpriseSearchTopology -Identity $cloneTopology" command i am getting following error message.

https://blogs.technet.microsoft.com/ptsblog/2013/09/19/configuring-sharepoint-2013-search-with-powershell/

Set-SPEnterpriseSearchTopology : Could not connect to the HostController service on server "WFE1" Topology Activation could not be started. At line:1 char:1 + Set-SPEnterpriseSearchTopology -Identity $cloneTopology + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidData: (Microsoft.Offic...tSearchTopology: SetSearchTopology) [Set-SPEnterpriseSearchTopology], InvalidTopologyExcept ion + FullyQualifiedErrorId : Microsoft.Office.Server.Search.Cmdlet.SetSearchT opology

To resolve this issue i did following things 1.Checked whether "search host controller" started in my WFE1 and its started.

2.Checked "SPAdmin and SPFarm" service account available in WSS_ADMIN_WPG and WSS_WPG

But no luck....

3
  • Did you try run the script on WFE1?
    – Jussi Palo
    Oct 11, 2016 at 5:49
  • What account is the SharePoint Search Host Controller service running as? If it's not running as the farm account, change the account it is running under to the farm account in the 'Configure Service Accounts' area within the 'Security' area of Central Admin and try again. Oct 11, 2016 at 11:12
  • Farm account and its working fine
    – user52682
    Oct 11, 2016 at 12:32

1 Answer 1

0

Try checking the application logs in event viewer. I was seeing this error:

Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance Reason: A call to SSPI failed, see inner exception. Technical Support Details: System.ServiceModel.Security.SecurityNegotiationException: A call to SSPI failed, see inner exception. ---> System.Security.Authentication.AuthenticationException: A call to SSPI failed, see inner exception. ---> System.ComponentModel.Win32Exception: The encryption type requested is not supported by the KDC

Based on that this resolved my issue: https://social.technet.microsoft.com/Forums/lync/en-US/1d4ba209-0f67-4a5a-ae71-a8d7c06e85e7/activating-search-topology-is-throwing-an-exception?forum=sharepointsearch

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.