0

My SharePoint 2013 Search Service application seems to be pegging my CA app (App01) server's resources whenever it's running its scheduled crawls. This led me to the decision to move the entire Search Service Application to its own server (App02).

I found this blog post detailing how to move specific components. The blog's script moves everything except the Admin and Index components. Is there a reason for leaving the Admin and Index components in their original location? Also, when I got to the part where the script creates the new components on the new server,

New-SPEnterpriseSearchIndexComponent -SearchTopology $clone -SearchServiceInstance $svr2

I get an error,

New-SPEnterpriseSearchQueryProcessingComponent : The search service instance on this server is not online

Am I supposed to run "Start-SPEnterpriseSearchServiceInstance" to start the Search Service instance the new server before running the commands to create the new topology components?

0

You can move all components. I would recommend having all components on both servers, however, for redundancy/load balancing purposes.

Yes, you must run Start-SPEnterpriseSearchServiceInstance prior to cloning the topology, etc.

  • Thanks Trevor. I'll give that a shot and post my results. – OddyKnocky Oct 10 '16 at 21:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.