1

A week ago I roll out this solution automatically map your SPO Document Library .

Everything was smooth until i changed the password of the user account. Now I get the error :

Mapping target: \xxxx-my.sharepoint.com@SSL\DavWWWRoot\personal\xxx_xxxx_xxx_xxx\Documents failed to contact O: after mapping it to \xxxxxsharepoint.com@SSL\DavWWWRoot\sites\Documents, check if the URL is valid. Error: Access Denied. Before opening files in this location, you must first add the web site to your trusted sites list, browse to the web site, and select the option to login automatically.

So I am in the middle of troubleshooting I got the conclusion the workaround is either Sync the library or open the document library with explorer, manually.

enter image description here

I am looking for a PowerShell that at least launch the sync application or "Open with Explorer"enter image description here

Any suggestion?

  • I think when you need to rerun the powershell script again to remap with the current credentials as the old mapping is using the old password, renmapping with the ps code should fix the issue. – Ali Jafer Oct 16 '16 at 15:15
  • I did several times, as well I synchronized the AD sync tool password. Yet not changes – LR2007_ITA94 Oct 17 '16 at 8:13
0

After I turn on fiddler and start to analyze the WEBdav traffic, I noticed the frames which try to connect with O365 missed the FedAuth and rtFa parameter in the Headers/cookie.

Armed the next Open source solution , I was able to fix the problem and keep stable my Disk mapping, bypassing the cookies issue.

Another important thing are

  • To keep regular password synchronizations towards Azure.
  • Keep free of error Download Center and OneDrive For Business client.
  • Implement different GPO that keep the SSO and cokkie freshness.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.