3

I am trying to upload a app generate with SharePoint Framework to the App Catalog of my SharePoint, but when I upload it, it don't recognize how a valid package and I can't add this app to my developer site where I upload the workbench. I don't see the app in the list of available apps for add.

I tried do all of the SharePoint framework guide but I don't accomplish upload a valid app.

enter image description here

Too, I tried to upload here the workbench but it don't work.

I hope your help for can deploy the app.

3

Maybe you have to try to do things again. In the guide, you should

Open package-solution.json from the config folder. The package-solution.json file defines the package metadata as shown in the following code:

{
    "solution": {
    "name": "helloworld-webpart-client-side-solution",
    "id": "ed83e452-2286-4ea0-8f98-c79d257acea5",
    "version": "1.0.0.0"
    },
    "paths": {
    "zippedPackage": "helloworld-webpart.spapp"
    }
}

When this is done, run the gulp command

gulp package-solution

The command will create the package in the sharepoint folder: helloworld-webpart.spapp

So far so good, next

Upload or drag and drop the helloworld-webpart.spapp to the App Catalog.

... and click Deploy.

When I do this, I get a ProductID on my dev-tenant App site, but from your screenshot I can tell that there is no ProductID, and maybe that's where things fail?

enter image description here

Another option, which you might have missed, is to install Drop 4 and upgrade your web parts? I had these issues doing a demo, and later on when I upgraded to Drop 4, everything worked like a charm. See Release Notes Drop 4 and MDL2 on how to upgrade your apps.

  • I try to do all guide against and it works perfectly in local enviroment, but when i go to upload to the App Catalog it don´t recognise how a valid package. My main problem is when i upload it, i dont have the message to deploy it. I have admin permission for 365 site. I dont know why it dont work. – Jesús Velasco López Oct 6 '16 at 8:40
2

Make sure you are using a Developer Tenant, not a developer site.

  • But, if i want to use the app to a exist project of office 365 with my account of it? I can´t include the app build in it? – Jesús Velasco López Oct 6 '16 at 7:48
  • 1
    For now it only works on a Developer Tenant, use on other tenants will come later. – Per Jakobsen Oct 6 '16 at 9:07
0

Your solution name might be too long (in "package-solution.json"), the limit is 64 characters. Keep it <= 64 characters.

enter image description here

I had a similar problem here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.