1

First when I tried to activate community site feature, it gave me the below error:

Site The Site scoped feature being activated has a dependency on hidden Site Collection scoped feature 'FeatureDefinition/15/4326e7fc-f35a-4b0f-927c-36264b0a4cf0' (ID: '4326e7fc-f35a-4b0f-927c-36264b0a4cf0'). Hidden features cannot be auto-activated across scopes. There may be one or more visible Site Collection scoped features that auto-activate the dependent hidden feature.

And 3-4 messages similar to above message.

So I then activated 'SharePoint Server Publishing Infrastructure' at site collection level and 'SharePoint Server Publishing' at site level. And then I tried again to activate 'Community Site Feature' and I got the below error:

"Cannot add the file /sites/mySiteName/SitePages/Community Home.aspx because it is a draft item"

Does anyone have any idea, how to resolve this ?

1

The page /sites/mySiteName/SitePages/Community Home.aspx was already created in site pages library despite of the error and it was checked out to me.

So I went to versioning setting of the Site Pages library and checked the 'No' radio box in the option 'Require documents to be checked out before they can be edited?'

And then I tried to activate the Community site feature and it was success.

0

I just ran into this in a new/modern SharePoint online site. And I created 2 site collections after thinking maybe I'd just not turned on features in the right order or done something else incorrectly the first time. It happened on 2 new, fresh sites with no content or changes.

The only way I could get around the draft error was to edit EACH page that got created (because they were all created when I tried to activate the feature, despite the fact that the feature didn't actually get activated) and delete the webpart that said it was unable to display without the Community Site feature being active. Then I saved and published each page. I then, ALSO, had to check out the page (I had turned the versioning setting ON -- it was off by default and still hadn't worked and kept talking about draft mode in my previous attempts). With the versioning turned on, I was getting an error saying to check out the files. It's possible, with versioning turned off (the default/initial state), it would have worked after I deleted the webparts giving me the errors, but I didn't go back and change that to test.

So, at the draft error message, edit the pages that were created, delete any webparts in those pages that are giving an error, save and publish, then try again (and check out if you have versioning turned on).

The community pages that are created definitely appear to be the "old" SharePoint pages -- so I suspect there's some updating MS needs to do if they plan to keep that feature as an option on modern sites. But I was looking to see if I could get a member/people page set up and since that's built in to the Community Features, I wanted to activate it to see if it can give me what I needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.