1

I am having trouble getting a Person's email address from a Person or Group column (named SharePointUser). The Person's email address is visible to me in the list itself, however, in the workflow all I can seem to get is the Person's unique ID.

enter image description here

I have tried all the possible Return field as options and here is what I get:

SharepointUser As String: 540
SharepointUser Display Name: 540
SharepointUser Email Address: 540
SharepointUser Login Name: -1
SharepointUser User Id Number:  540

I also tried the suggestion posted at this question, however, I get a Workflow failed to get user profile for user:540.

Grr. Not sure why this is causing me such trouble! I can see the email field right there on my list! Why are you hiding from me?!

  • Do you have the user rights, that you are using to log-in? – Ram Oct 4 '16 at 4:50
  • Please go in the Site Settings => Open the User Group Settings(From which User_group you are getting the User) => Who can view the membership of the group? is this Everyone? – Ram Oct 4 '16 at 4:53
  • @Ram - I went to Site Settings: People & Groups: Group Settings (for each group). Some were set to "Everyone" and some not. I changed them all to "Everyone". However, I still have the same issue. – thornomad Oct 4 '16 at 17:20
  • Which Workflow you are using? If you are using 2013 then use App Steps & 2010 use Impersonation Step. Hope it would be help you. – Ram Oct 5 '16 at 5:10
  • @Ram - It's a 2010 Workflow. I will test that, however, I am the Workflow Author and a site owner and the creator of the list and the one initializing the workflow ... – thornomad Oct 5 '16 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.