I would like to create a contact list containing both Persons and Companies. Is this possible at all?

The issue is that companies do not have last names, which is the title column.

When I link the contacts app to outlook, I can import contacts without last names which will show as "no title". They however can't be edited without adding a title. Also I won't be able to create new companies without completing the Last Name field.

I thought another potential solution was to change the mapping between the list and outlook, but haven't been able to find information on this.


Create a new custom view and set the columns as you required fields.I think this is the best and simple way to handle this.

  • Can you provide a bit more details? I do not see a way around completing the Last Name field when trying to enter a company. – G684 Oct 3 '16 at 16:00

Through List Settings > Advanced Settings, enable content type management. Then via List Settings, edit the default Item content type and click the Last Name field. Change it from Required to Optional and you should be able to create items without values in the Last Name field.

  • I'm able to switch the Last Name column status to Optional and the required asterisks disappeared when creating a new item. However, when I try to add an item is still shows an error message saying the field is required. – G684 Oct 5 '16 at 7:55

I also had trouble with sharepoint requiring last name. sharepoint stock contact app has last name required, I tried everything to fix this. solution was to rename the last name field to something else I wanted to require. In my scenario, I wanted to list businesses, which had no contact name and people with their first and last name, but I was being required to enter last name for businesses. So I renamed the required column called "Last Name" to Business Name , this made that field a required field. Then I created a new column called "Last Name" which was not a required field. Viola! This solved the problem!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.