0

I have created a web application which uses port 80 and i have extended the web application at port 443 which is a SSL enabled site

Example:

http://myportal (port:80 -Default Zone -Windows Auth)

https://myportal (port:443 -Intranet Zone -ADFS authentication)

I have added the http web application to the local SharePoint site's content source.I ran a full crawl and tried searching in http site,the search works fine but when i search in https site,its displays "Internal server error exception:".

Kindly let me know if I need to do any more configuration for https search to work?

Please note: I am using a service account as the default content source account.

Below is the error in ULS Log:

'Service Service Application Proxy', scopes manager: adding OOB consumer objects for consumer '155dc91d-dcdb-46ce-a958-2866f5cefff5'

'Service Service Application Proxy', scopes manager: could not AddConsumer name: 155dc91d-dcdb-46ce-a958-2866f5cefff5 due to exception:

Microsoft.Office.Server.Search.Administration.DeletedConcurrencyException: No site collection named "{155dc91d-dcdb-46ce-a958-2866f5cefff5}" could be found. at Microsoft.Office.Server.Search.Administration.Consumer.get_SPSite()
at Microsoft.Office.Server.Search.Administration.Consumer.get_Url()
at Microsoft.Office.Server.Search.Administration.ScopesManager.OnConsumerAdded(Consumer consumer) at Microsoft.Office.Server.Search.Administration.RemoteScopes.AddConsumer(String consumerName, ConsumerCollection owningCollection)

SearchServiceApplicationProxy::DeleteConsumer--Proxy Name:Service Service Application Proxy EndPoint: http://usviaspeu001:32843/2988e5665732449d8c895dea4765f654/SearchService.svc

| |