1

I have a situation where 1 user anytime she open an Excel file from our SharePoint folder via the client and then closes (via the x, not File/Close) the file no one can open this file without getting the dreaded message "file locked by user". I have confirmed she no longer has the file open so what is creating this issue.

Note the document folder does not require check out. Also, I noticed even after she shut off her PC it was 15 minutes before the file became available.

Note when the file becomes unlocked I can open the document/select Edit document, make changes to the document, immediately close the document and others have no issue with a lock even within 10 minutes. Why is SharePoint Services putting a 10 minute lock on her instance but not my instance.

Also, when the individual who is creating the lock issue closes out of the file it remains locked for indefinitely. Only shutting down the PC removes the lock.

1

1) Take backup before any other step.

2) Check you upload center for any kind of error or document paused, and delete them. enter image description here

3) As well try to delete the Content.MSO cache depending on what is your OS version client the exact path could change:

In windows 10 for example is this C:\Users\\AppData\Local\Microsoft\Windows\INetCache\Content.MSO

earlier version could aim this path: C:\Documents and Settings\UserName\Local Settings\Temporary Internet Files\Content.MSO

4) When path is clean I would reboot the machine to me sure turds are dump. 5) Log in again and start to work with document.

  • I will try this in the morning and let everyone know how this works..many thanks – daPlayaURH Sep 30 '16 at 2:37
  • That did it ! Any reason why this occurs... Also what we had to do was clear the Upload cache for both the initial person who opened the file and then the person who subsequently tried to open the file and got the lock message.. – daPlayaURH Oct 1 '16 at 1:29
  • after dealing with locks for a long time and frustrated users waiting 10 minutes, tried this and it worked immediately. not sure it works for all scenarios but definitely something great to keep at hand. thanks. I suggest to use this path: %LOCALAPPDATA%\Microsoft\Windows\INetCache\Content.MSO – Tiago Duarte Mar 14 '18 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.