0

I'm getting a '500 internal server error' while trying to access any web application other than the central administrator page. This problem appeared suddenly when I tried opening the sites. No password change have been made on the server side; also I have verified all the application pools are in the started state only. I have checked by creating a new web application; still, the same issue occurs. I have also tried by changing the identity of the specific web application from IIS, but it doesn't work. I was not able to set the username and password for identity over the advanced settings of SecurityTokenServiceApplicationPoolService in the application pool as it is saying 'invalid credentials'.

SharePoint is installed on SQLServer 2008 R2. When I checked Event viewer I'm getting two warnings and two errors. Two errors saying Claims Authentication(8306) and warnings as configuration(8059) (I know this Question was already asked in the SharePoint community but the answers did not solve my issue so that I'm asking it here)

  • Restart the server, and then try. – P S Oct 6 '16 at 11:28
  • already tried.IIS reset also tried – Sribin Oct 6 '16 at 12:16
0

As you were not able to change the settings of the STS it seems there is something wrong with your service account. Check that it is not expired, locked or disabled (or even deleted). If those are ok, add it as an admin to test server and try to log in with that account.

Issue might be not located on the Sharepoint server if accounts proves to be ok check with your infra team time sync between the SP servers and domain controllers.

If none of the above applies do more checking with ULS logs turned on to verbose mode.

You can change verbosity by running PS command:

Get-SPLogLevel #check logging lever Clear-SPLogLevel #set logging lever to default.

Set-SPLogLevel -EventSeverity verbose -TraceSeverity verboseex #Set max level of logging.

  • I'm new to SharePoint and finding it bit hard to follow this. – Sribin Oct 6 '16 at 13:06
  • 1. Check that it is not expired, locked or disabled (or even deleted) - check that with anyone that deals with AD accounts. – Marek Sarad Oct 6 '16 at 13:18
  • 2. For ULS troubleshotting please google or check other questions on the StackExchange, this is really basic for SharePoint troubleshooting, and Q&A type response is not suitable for this purpose, sorry. – Marek Sarad Oct 6 '16 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.