We had a tiny console app. that index some content of a Sharepoint 2010 site. Among that data, we need to index the user rating per content.

We use the following code to do it:

//content and url are previously initialized correctly
SocialRatingManager ratingManager = new SocialRatingManager(context);
SocialRatingAverage srAverage = ratingManager.GetAverage(new Uri(url));

This code worked perfectly in the old server. But our client needed to migrate to a new one and here it's not working. It's throwing the following error on the first line:

No User Profile Application available to service the request. Contact your farm administrator.

I'm pretty sure has something to do with Windows or Sharepoint permissions. I've found this possible solution in several articles: http://www.c-sharpcorner.com/Blogs/4344/

Problem is, we don't have the ribbon bar in that page. We do have a link 'Manage User Permissions" under People. So we tried giving everyone (not sure which user should be exactly) permissions to Use Personal Features, Create personal Sites and Use Social Features. But the exception is still being raised.

Any idea how to fix this?


1 Answer 1


I managed to fix the same using the one of method suggested in this blog

  • It's the same method as suggested on the link I posted.
    – empz
    Commented Sep 16, 2011 at 17:02
  • Ok, so I found the ribbon appears when selecting the row, not when actually clicking the "User Profile Service Application" text. But, what's the account it needs to be added there? My user login or some .NET or Sharepoint account?
    – empz
    Commented Sep 16, 2011 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.