1

The hide feature in Site Settings under navigation is not working. I select the site, click hide then press save. Immediately after clicking save, SP reverts all my hidden sites back to its original state->Show. I have full rights to this site, and the issue is happening in SharePoint 2013 Enterprise. Current and Global Navigation are set to "Structural Navigation: Display the navigation items below the current site". Show subsites and Show pages are checked. I don't know what could be causing the reversion. Everything including sorting and adding links seems to be working except the Show and Hide feature.

Help :-(

1

I realize that this is an older question but I thought I would answer it since I just ran into the same situation and couldn't find a solution through searching.

Items that cannot be hidden through the Navigation Settings on a site can be set to hide/unhide by clicking on "Edit Links" in the Global Navigation menu.

You'll see that in the second screenshot that in Navigation Settings, I have the option to Hide it but once I hit OK, my changes revert back to the unhidden state.

As I mentioned earlier, if you click on Edit Links you have the option to click the "eye" icon to hide that menu item. The third screenshot shows after I clicked on the icon to hide it.

Once you make your changes through that menu you can go back into Navigation settings and verify that the items are in the state that you want them to be in. You'll still run into the same issue where you can't unhide them through Navigation Settings. You'll have to do that through "Edit Links" again.

Screenshots

It looks like there's another topic on a similar problem, if not the same thing. In that topic, they mention the October 2016 CU to fix the Navigation Settings bug so maybe that topic will help anybody needing it as well.

I hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.