1

I have dev environment with SQL and Sharepoint 2013 installed on same machine. My C drive was full so i moved "WSS Logging" data base to another drive. After movement none of my site collections are working apart from Central Admin.

I can not even create a new web application ans it throws following error:

The file "C:\Program Files\Microsoft SQL Server\MSSQL10_50.MSSQLSERVER\MSSQL\DATA\db.mdf" is compressed but does not reside in a read-only database or filegroup. The file must be decompressed. CREATE DATABASE failed. Some file names listed could not be created. Check related errors.

EDIT I used below mentioned URL to move DB. https://dba.stackexchange.com/questions/52007/how-do-i-move-sql-server-database-files

Waqas's solution below worked for New application but i still can not access the existing site collection. I am getting below error:

HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid

  • How did you perform the database move onto the second drive? Have you checked the permissions applied to the folder(s) containing the mdf and ldf files? – Andy Dawson Sep 19 '16 at 11:49
  • I have added the details of how i moved the DB – Mohit Sep 19 '16 at 12:24
  • Can you provide any further details of the errors? Can you turn off the call stack (CallStack="false") and custom errors (customErrors mode="Off") in the web application web.config file for one of the affected web applications and provide the output it should give? – Andy Dawson Sep 19 '16 at 13:07
  • 500.19 is usually related to malformed XML in the web.config file - do you have a backup of any of the web.config files that you could compare with the one that's currently on the machine? – Andy Dawson Sep 19 '16 at 13:12
1

this error telling us, the new location is under compressed folder. In this situation, you have to uncheck the Compress contents to save disk space.

  • Right Click on the Data Folder > click on Properties
  • Under General Click on Advanced
  • On this page make sure Compress contents to save disk space is unchecked

If it is uncheck, go to up folder( MSSQL10_50....) and so on.

check this

  • Thanks Waqas. Your suggestion worked for creating new applications, but i could not access the existing site collections yet – Mohit Sep 19 '16 at 12:26
  • what error u are getting for the existing site collection? what are the status of Database in the central admin? may be need to clear the config cache... – Waqas Sarwar MVP Sep 19 '16 at 12:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.