2

In SP 2010 if I do search on home page of site then will show me results from all lists. If I am inside a particular list and then search something then it shows me results from that particular list only.

But in SP 2013 the behaviour is different and even if I am inside a list, when I search something it brings result from whole site.

I can see that in SP 2010 it is sending query string parameter u=http://myserver/mywebsite/mylist while in SP 2013 it always sends u=http://myserver/mywebsite

How do I enable same behaviour in SP 2013?

I am using default search box that is normally shown on top right corner.

3

How do I enable same behaviour in SP 2013?

Unfortunately , you can't do the same behavior in SharePoint 2013 at the default search box that is shown on top right corner,

This due to SharePoint 2013 introduces the Enhanced List toolbar feature, so the Search behavior has been divided into two section

  • [Search this site] this the search box that is shown on top right corner
  • [Find an Item] this the search box at the Enhanced List toolbar.

enter image description here

So if you need to search only for the current list , you should use Find an Item search box.

3
  • Very strange that I don't see this search box in any of the library although I see it in lists. – Frank Martin Sep 17 '16 at 14:40
  • I get it that it is not visible because I am using "Server Render" option in library. – Frank Martin Sep 17 '16 at 14:45
  • You can get it . by editing your web part > Miscellaneous > Check display Search Box, and you are right if you enable server render , the enhanced toolbar will be removed – Mohamed El-Qassas MVP Sep 17 '16 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.