2

I have a document library that has unique permissions. A SP group has only rights to view documents in the library. All documents inside the library inherit the access rights from the library (so no unique permissions there).

Now there is a strange behaviour. The library contains pictures (jpeg, png) and also files like pdf etc.. Providing a user with a link from a jpg in the library he is able to open that jpg. Providing the same user with a link to one of the pdfs in the library he gets an permission error (this site has not been shared with you). So all pictures can be viewed but no documents. Strange...

I have to add that the view right is very limited. The users cannot go to the teamsite and browse the library directly. They can only access the files if they know the direkt link. This has worked for a long time and still works on a copy of the affected Teamsite with exact same permissions set.

I wonder if anyone ever had a problem like that and can help.

  • I found out that documents can be opened if ?web=1 was added to the URL. With ?web=0 the permission error occures. I guess on the production system the office web apps are included (and mandatory?) and on the testsytem they are not. There it makes no difference if I add ?web=1 or = 0 to the URLs. I tried to change the document opening behaviour in the settings of the document library but with no effect. Any help appreciated. – Worn Sep 16 '16 at 14:06
  • Did check the exact permissions applied to the View Permission level. You can do that from --> Site settings-->Site permissions--> Permission levels – Unnie Sep 16 '16 at 14:24
  • Checked that, both test and prod. systems are the same. Did not change the permissions. And it did work, but now it seems as if the download right ist gone or so. – Worn Sep 16 '16 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.