I create reusable worflow in SharePoint designer, Everytime I modify the workflow and attach it to the library a new column for the workflow is being created. They are not even shown in library settings. Can any one help me how do I remove those old workflow columns.

  • Hi Paddy, just to make myself understand your question better - do you mean that every time you modify the workflow that is attached to the library, it auto-create a new column in the workflow itself ~or~ do you mean that every time you modify the work flow that is attached to the library, it auto-create a new column in the library?
    – Wilson Tan
    Sep 16, 2011 at 7:36
  • Hi, for me when i remove the worflow attached to the library the corresponding column is not being removed. So every time, I attach and remove workflow Columns are created newly even if the same name exists already.
    – Strider
    Sep 16, 2011 at 8:09
  • You are using WSS3? or SharePoint 2007? or SharePoint 2010?
    – Wilson Tan
    Sep 16, 2011 at 8:27
  • Its SharePoint 2010
    – Strider
    Sep 16, 2011 at 9:28
  • We have the same issue. Deleting a sharepoint designer 2007 workflow in sharepoint 2007 did not remove this system generated column, therefore, we can not reuse the column name. We want to reuse the column name as the Access report created for this List uses the column name we are looking to reuse. Please advise. CAROL
    – user7666
    Apr 2, 2012 at 17:25

4 Answers 4


You can remove them from view by modifying the library view and unticking the oxes so they are not displayed.

Removing old instances of your workflows should help as well. Go to the library settings --> Workflow settings --> Remove a workflow

  • Unchecking the boxes removes only from the display... Even I removed the old instances of the workflow. Both did not work.
    – Strider
    Apr 2, 2012 at 3:13
  • Why do you want to remove them completely? Is removing them from view not enough?
    – Enilorac
    Apr 2, 2012 at 7:32
  • Too much of duplicate columns getting accumulated... for the same workflow...
    – Strider
    Apr 3, 2012 at 3:04
  • Ah I see, sorry I couldn't be more help
    – Enilorac
    Apr 3, 2012 at 8:21

There isn´t a simple way of removing old workflow status columns in SharePoint. You would have to remove them by code.

See the following urls for reference, and how to solve it:



  • 1
    Welcome to the SharePoint SE. We try to avoid posting just links as answers as it's not uncommon for blog posts to be deleted or moved. Could you add at least a high level overview of the steps to your answer to improve it? Jan 19, 2014 at 19:30

This can be easily fixed right in SharePoint Designer (2013). Open the site. View the List. View the columns in the list. From the toolbar, click view Read-Only Columns. Delete the offending workflow status columns. Pretty easy.


Its not that easy, but it worked for me. Follow the steps below:

  1. Download SharePoint Manager to one of your SharePoint servers
  2. Open SharePoint Manager and then navigate to your desired list and select the field that you want to delete.
  3. Set "AllowDeletion" to True from drop down, which will be blank at the beginning.
  4. Make sure to click on save all icon.
  5. Open SharePoint designer, click on lists and libraries from the left navigation, click on your list, click on edit columns from the ribbon menu, click on show read-only from the ribbon menu, select the desired read only field/column that you want to delete, and then finally click delete from the ribbon menu.
  6. Click save from the top left of the designer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.