1

I have a strange issue that appears not to have come up for anyone before (after MUCH searching online), although I hope to proven wrong :)

I have a list that uses an Info Path 2010 form to collect data from assorted users. It has been working fine for quite a while until recently when a user reported that their entries were missing. Sure enough, when I checked, the ID's they gave me were indeed missing, from ALL available views. I have created new views with no conditions/filters, and still nothing. I have created a view for these items specifically, and still nothing.

The user knew the ID's of the items they raised, so I tried going directly to the items via URL (replacing the ID= portion) and it worked, so the item DOES exist... I also imported the list to MS Access and again the item is there. So it seems to be a SP specific issue.

Any ideas? I am conscious that this only the case for items created by this one user, but I can't find any reason why that would matter when you consider they have the same list level access as everyone else, in addition to the fact that the items are missing across all views (so it's 99% sure not a filtering issue).

Can SP list items get corrupted? If so, would they be available via direct URL / via MS Access import?

Using SP 2010

  • sadly, I can really think of an answer with the few details that you posted. Still, something you said caught my attention. "I can't find any reason why that would matter when you consider they have the same list level access as everyone else" - are the other users able to view the items this user can't? If so, then there must be something different about him/her, no doubt about this.... but if no one can see the items then this seems to point at the item creation process faulting somewhere and leaving the items in an incomplete state. – SPArchaeologist Sep 12 '16 at 18:11
  • Because of this, I would try and check the logs to see if: a) there is an error in the InfoPath step - the form is having problem in "posting the data", b) there is some even receiver that performs some action on the file (maybe a check-out under system user credentials??) or even c) a workflow hanging the file indefinitely in "adding" status. I seem to remember something similar happening when we found a receiver on a document library causing an endless loop under some circumstances... items would appear only after a while, when the process time-out... – SPArchaeologist Sep 12 '16 at 18:15
  • @SPArchaeologist - Apologies for responding via an answer and not commenting on your response, but for some reason my question is not linked to my account and it's not letting me comment :S To give a bit more detail: Nobody can see the missing items in the list view, but everyone can see the items if they open them directly via URL (i.e. MYSHAREPOINT/sites/MYSITE/Lists/MYLIST/Item/…*PUT THE ID OF THE ERRONEOUS ITEM HERE*) I also don't think it's an item creation process fail, because the items have been kicked through a few statuses already (by this I mean I – Karl Major Sep 13 '16 at 16:18
  • Weird. The only two times I saw such behavior were once for some folders and then for some items inside a document set. In both case the culprit was custom code that created the folders in the first case and the items in the second one - the procedure that was used wasn't correct and ended up in "corrupted items". – SPArchaeologist Sep 13 '16 at 17:53
  • @Karl - Do you have updates on your issue? I'm seeing the same behavior in one of our lists... Any tips/guidance would be very helpful. Thank you! – Guest Nov 18 '16 at 10:34
0

Possible Work around: Check "Show all items without folders" for your views.

Possible Issue: For whatever reason, the item is being stored with-in the Item folder inside the list. It is a system folder and not visible in views.

I had this same issue with one of my lists with an infopath form. Every now and then an item would be missing, but could be searched, or manually viewed by editing the URL with the Item ID. Super annoying. Working with MS, this was our work around.

0

Low likelihood of being correct, but is the list moderated? Or version enabled? Either one could contribute to some of the symptoms you mention (alas, but not all). Typically, you see this on libraries as opposed to lists. But, it's easy enough to check: List Settings > General Settings > Versioning settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.