2

I'm using SharePoint Designer 2013. I need to open one of my custom lists to edit it's view in SharePoint Designer.

I found that I need to click on 'Customize XSLT' button in List View Tools tab for editing the view. But I can't find where it is.

I clicked on different parts of the code to make it available on the ribbon. But it doesn't seems to have a tab called 'List View Tools'. What should I do?

2

This is a common issue with SharePoint Designer 2013. You can follow the following simple steps to get the List View Tools tab back easily.

01.) Right click on a tag in the code and select 'Tag Properties'.

enter image description here

02.) click OK button on the opening dialog box.

enter image description here

03.) Now you'll see the 'List View Tools' tab in the ribbon and you can find the 'Customize XSLT' button in the Design tab.

enter image description here

But you'll have to follow this method to view the menu each time you visit this page.

2
  • 1
    This is exactly what I was looking for. Thanks for saving my day. Sep 12 '16 at 14:14
  • @Jake - When I right click the tag and select Tag Properties, the Page Properties dialog box comes up. After I press okay, nothing happens. It keeps asking me if I want to have the Advanced Mode on.
    – cbbrown
    Aug 4 '17 at 18:04
1

To get Customize XSLT

  • After you have already added your Data View from Insert Tab> the list view should be now added and its tags are selected.

  • Now you should see List View Tools > go to Design Tab > you will find Customize XSLT as shown below

enter image description here

Note: If you have already added the list view and you can't find Design Tab

  • Click on the end of List View tag <\WebPartPages:XsltListViewWebPart > the List View Tools should be shown now

Check the detail steps at MISSING LIST VIEW TOOLS IN SHAREPOINT DESIGNER 2013

3
  • I created a new view for my library and changed from the default style before I brought it into SP Designer. Now when I open up the view and place my cursor in the web part tag, my tool bar still does not show up. I've even tried right clicking and opening up the Tag Properties and the only thing that opens is the "Page Properties" dialog box.
    – cbbrown
    Aug 4 '17 at 18:07
  • check the attached link , and feedback me if it worked or not Aug 4 '17 at 19:02
  • I highlighted the "Parameter Bindings" and still nothing happened. I created a new view with a non-default style and then opened that view up in SharePoint Designer 2013 to try and export the webpart. I watched this youtube clip: youtube.com/watch?v=eN4Rq6cAyP4 starting around 6:53 where she does this exact thing. I'm guessing that it turns it into a data view?? If not, please correct me.
    – cbbrown
    Aug 4 '17 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.