0

I am currently trying to deploy a timer job to my SharePoint site. for the first deployment I forgot to implement a public default constructor for the Timer Job Class. And now I am stuck because I cannot retract the old solution and update it with the newer one with the public default constructor implemented.

I have already tried it with the Manage farm solutions page and got an error like this:

enter image description here

I have also tried this one here:

Uninstall-SPSolution -Identity testproject.wsp -allwebapplications
Remove-SPSolution -Identity testproject.wsp -force

With the same error and I am driving crazy right know because I don't know any more solutions to handle this error.

Can anyone tell me how I can "kill" the corrupted solution from my farm so that I can deploy the correct one?

EDIT: I have also tried the "Update-SPSolution" but get the same error...

  • Have you tried Update-SPSolution ? – Sudhakar Sep 9 '16 at 10:16
  • @Sudhakar yes and I am getting the same message... – Snickbrack Sep 9 '16 at 12:15
1

Snickbrack,

Please try to copy your DLL to GAC directly. You can do this manually or use some VS plugins like CKSDev or Fishbone

  • Yes, this made it! I have done it with CKSDev and Mavention. Thanks – Snickbrack Sep 12 '16 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.