0

I have a list that uses a unique content type which has several site columns of the type managed metadata field.

I have a managed metadata property for each of these taxonomy fields that is mapped to both crawled properties corresponding to that field, for example if my field has the internal name "Location", then my managed metadata will also have the name "Location" and it will be linked to both:"ows_taxId_Location" and "ows_Location". This goes for all these fields.

Recently, searching those items by these managed properties stopped working, here's the problem:

Let's say that a specific item has the Location field set to Paris. If my search query is Paris then the results will be shown as expected and the item will appear in the search results box. However, if my search query is "Location":"Paris" then I get no results. Also searching by "Location":"*" will not return any results from my list. Until recently this was working fine, I did not perform any changes to the list or the managed properties or the search service or the items.

In addition, for some of these managed metadata fields I noticed that the queries work normally for 3-4 list items. (I have hundreds of possible values and thousands of items). So "ManagedPropertyName":"*" returns only 3-4 items, despite the fact that there are a lot more items that have a value in that field.

Moreover, all the queries above work fine for items belonging to other lists that use the same metadata columns site column.

It's not something related to results type since I can find any item if I search by its title

I tried these queries on an OOB Search Page and I made sure that no option that removed the duplicates is enabled. I tried to re-index the list and I runned several full crawls but it didn't seem to work. I used the search API to retrieve those items that had problems and these taxonomy fields are empty. Except for this incident, there are no problems with the search service.

Can you think of any solution or recommend any course of action?

0

As a recomended course of action:

Try the "Ultimate diagnostic display template" - are the properties really (really, really) crawled indexed?

Also I had some luck using the "SharePoint 2013 Search Query Tool".

If the taxonomy fields on the list items do not appear correctly in the crawled content, it could be some error in the hidden TaxCatchAll field. Also, if the "Taxonomy Update Scheduler job" fails or is not running the crawler ist not able to crawl the taxonomy "values" on the item. Andrew Connell has a real nice article on the inner workings of taxonomy.

  • Thanks Nils, those are really neat tools. I used the Search Query Tools and I found out that the managed properties are only set for some items, for the others the properties are not set. I'm not sure why this is happening, it's not related to the time they were created or the time they were last modified. I looks as if half of those items were simply ignored by the crawl. Which is even weirder considering that not too long ago they were all working fine – Radu Bucur Sep 7 '16 at 16:47
  • Have you checked the status of the "Taxonomy Update Scheduler job"? What is the status of the hidden TaxCatchAll field on the items that are no longer "findable"? – Nils Sep 7 '16 at 18:53
0

Same problems here. Root cause is that our items has a incomplete value of hidden field 'TaxCatchAll'.

Background: 'TaxCatchAll' field is an array of "CatchAllData" data. One array element per term value used on your item. The "CatchAllData" should have the same values of the term in the TaxonomyHiddenList.

Problem is that sometimes our "'TaxCatchAll' is not updated correctly. Certainly in these cases where we run a OnCreate (Nintex) Workflow on our items where we update our item!

I think that the Nintex WF creates an item update conflict with the update by TaxonomyItemSynchronousAddedEventReceiver. The latter wants to update 'TaxCatchAll'.

I haven't found a solution yet.... Any idea's?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.