0

I want to build a SharePoint 2013 Site workflow for SharePoint Online using SharePoint Designer. The idea is my workflow checks every day to see if a reissue date is equal to 4 months from the current date.

Add 4 months & -23 hours to Current Date and store in dateReissue .

In my Workflow history I see

   *The hardcoded (testing) or calculated ReissueDate is 2017-01-15T00:00:00Z* 

In SPD the Call HTTP request

        [%Workflow_Context:Current Site URL%]_api/web/lists/getbytitle('My List')/items$filter=(IssueDate eq '[%variable: dateReissue%]')

I do set the current date correctly in ISO format and the above request returns an Http OK however the response is empty.

Bizarrely, if I fire up Postman and run this query

         https//tenant.sharepoint.com/site/_api/web/lists/getbytitle('My List')/items?$filter=(IssueDate eq '2017-01-15T00:00:00Z') 

I get nicely populated json response ;-).

I have tried hard coding the date in SPD but I simply can't replicate the desired response, I am seeing in Postman .

0

As usual 2 heads are better than 1: My boss and I worked through this issue on Friday. We so realised that the Postman REST request uses my identity so can see draft docs whereas SPD effectively runs under another identity in App Step and can only see published documents. Hence the confusion . Aaaaahhhh!!!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.