0
  • I am generating the code in one my sharepoint list,And creating the item in one of document library by adding the generated ID of the list.And document library is designed with infopath forms
  • When I click on Infopath document it is opening in locally(desktop).But when I click on "New Document" in document library I am able to get the Infopath form in browser.

Can any one help me what is the issue and how can I solve this issue.

  • What's the SharePoint version ? are you have installed InfoPath at your local machine ? what's the Infopath version ? – Mohamed El-Qassas MVP Sep 4 '16 at 9:16
  • I am having the same issue on SharePoint 2013. On a new item, opens up in the browser, however on an edit item, it opens up in InfoPath unless I specifically click on the elipse and then edit in browser, this is not how users will use it though, they will just click edit, which opens up the filler, how do we change this? – Ike Rebout Jun 7 '17 at 20:54
1

Make sure that the Opening Documents in the Browser has been set to Open in the browser

  • Go to the Form Library to which you published the InfoPath form template.
  • From the above ribbon > Click Library setting > Advanced Setting
  • On the Form Library Advanced Settings: page under the Browser-enabled Documents category, choose Open in the browser

enter image description here

In some cases , you should Make Sure that the SharePoint Server Enterprise Site Collection feature has been activated at Site collection level. Also , try to republish your template again .

| improve this answer | |
  • Have done both of these. As stated, on new items it opens in browser, but on edit of an item it opens in the client, even with the "Open in Browser" Option being selected. – Ike Rebout Jun 7 '17 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.