1

While attempting Tutorial 1: HelloWorld WebPart, Step 6: Preview web part in SharePoint.I am having an issue that is preventing the SharePoint hosted workbench from loading the webpart. After receiving the initial unsafe scripts error in Chrome, I then allow for Load Unsafe Scripts as the tutorial states. I then receive another error with the following message "Error loading debug manifest script. (Error: http://localhost:4321/temp/manifests.js did not call System.register or AMD define. If loading a global module configure the global name via the meta exports property for script injection support. Error loading https://localhost:4321/temp/manifest.js) Ensure loading unsafe scripts is allowed.

I setup my developer tenant as instructed.To experience the behavior I click on workbench.aspx in the document library.I get the initial error message for loading the debug manifest script as shown in the tutorial. I then click the gray shield icon and Load unsafe scripts as shown in the tutorial.Next, I receive the error stated above.

When testing the webpart in my local workbench, everything appears to be working properly. I only have this issue while using the workbench.aspx hosted in SharePoint Online.

2

I was able to get it working. On a hunch, I updated both Yeoman and the SharePoint Yeoman generator and then created a new project. I'm guessing that there must have been an update to the SharePoint framework that was available in SharePoint Online and what was on my local machine. Updating seemed to fix the issue.

  • 1
    would you mind providing more detailed steps on updating both? I have very limited experience with the console commands. I'm in the same boat as you even though I only installed them two days ago. – Panoone Sep 6 '16 at 3:12
  • @panoone - Make sure you hit the local hosted workbench on https first and trust the unsigned cert before you hit the sharepoint hosted workbench, – PatMill_MSFT Sep 6 '16 at 21:11
  • Thanks, Pat. The trick was accepting the Cerys from both localhost and the gulp server address. There are still some known issues which I've documented on the official GitHub register but I'm at least able to work now. – Panoone Sep 9 '16 at 3:56
1

Make sure you accept the unsigned certs from your local workbench first. See this entry in github - https://github.com/SharePoint/sp-dev-docs/issues/165

1

I was able to get it working by opening a new tab in the browser (chrome) and loading up the resource with the error.

For example, the following URL was in the error message: https://localhost:4321/temp/manifests.js

When loaded in a new tab, the URL resulted in an certificate issue page where I used the advanced option to proceed. I did the same when I encountered another error referencing this URL: https://localhost:4321/dist/hello-world.bundle.js

Once again I opened the resource in a new tab and proceeded via the advanced option.

Then, I refreshed the original workbench.aspx in SPO and it rendered correctly.

0

I had this error, I closed and reopened command prompt and executed gulp serverfrom the project directory and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.