1

Last year we made a solution for a customers website (on a linuxserver). They also have a sharepointserver, where they update some numbers daily in an excel sheet, and use a macro to generate a public csv from those numbers. Then we had a small pythonscript on the (linux) webserver that downloaded the csv and generated a svg.

This has worked fine until about a week ago, when the sharepoint server suddenly started returning a html file instead of a csv. Earlier, if I tried going to the address of the csv, my browser asked if I wanted to download the csv file, but now I get a "Excel Online"-spreadsheet, where also some of the cells are wrong (seems the csv gets messed up because excel misunderstands the delimitors). The customer is pretty sure nothing was changed by them.

I am really out of my element with the excel/sharepoint-part, so - does anyone have some idea what is wrong or if something was changed by MS/sharepoint lately that could explain the change in behaviour?

  • Is that server SharePoint Online or on premises? – Nils Sep 3 '16 at 8:31
  • Have to check to be 100% sure, probably SharePoint Online (says "Office 365 | Sharepoint" in the header?) – Torstein Opperud Sep 4 '16 at 15:47
  • If you're using SharePoint online, Benny Skogberg's answer is a possibility. If the SharePoint is on premises the question would be which was changed on the SharePoint-Server. How do you download the csv? – Nils Sep 4 '16 at 16:52
  • The server address is "https://**companyname**.sharepoint.com" - and when I did a trace on that it seems XXXXXXXXXXXXXX.sharepointonline.com.akadns.net was the real server name, so I guess that means its sharepoint online :) – Torstein Opperud Sep 4 '16 at 19:06
2

This may or may not solve your problem, but either way it's worth trying. Microsoft recently changed to modern document libraries, which may have changed the behavior of your csv-file.

In your tenant admin site, go to settings > organization and turn off modern document libraries, which will switch back to "classic" document libraries. You can also, in the library itself, switch to classic mode, but it would probably not affect your Linux server script.

If this doesn't work you can try to switch on OpenInClient feature which is a site collection feature in site settings.

I know these suggestions are long shots, but it gives you something to work with.

  • This sounds very very likely and promising! I've asked them to get me an admin account now so I can check properly, but do you know if this is possible to do for only one document, or if I have to do it for all documents on their account/domain? – Torstein Opperud Sep 4 '16 at 15:42
  • @TorsteinOpperud Unfortunately, this is a tenant wide setting and will effect all your site collections. – Benny Skogberg Sep 4 '16 at 16:00
  • 1
    Alright, might still be interesting, will have a talk with the client tomorrow :) – Torstein Opperud Sep 4 '16 at 18:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.