3

I received a SQL content database backup file (BAK) from the customer. I restored it in SQL Management Studio. I set the farm account DB owner for this content database.

I try to set in CA the site collection administrator. But it doesn't work. The input field is empty/greyed out to set some username.

In the ULS I see this error:

Access denied.  You do not have permission to perform this action or access this resource.

Who knows what the issue is? I am using SharePoint 2013 on premise.

10
  • Are you Admin of the Web Application you mounted the DB on?
    – SunP
    Sep 2, 2016 at 8:27
  • I created the webapplication with sp-install account. I give the sp-install account full control on webapplication with the policy permissions in CA. Is this what you mean?
    – Ola
    Sep 2, 2016 at 8:42
  • I mean, if your admin account or your administrator group has full control on the Web Application?
    – SunP
    Sep 2, 2016 at 8:46
  • Yes is has full control to the web application. Still the same issue. When I select the web application and then the root site collection (/), I see 'no selection'.
    – Ola
    Sep 2, 2016 at 8:52
  • The database you restored was it a backup from a sp2010 system or an sp2013 system? Are you able to open the site and change Site Collection Admins under Site Settings?
    – SunP
    Sep 2, 2016 at 8:57

3 Answers 3

0

Try to open your Central Administration as Administrator, If still grayed out , try to set it using SharePoint Management shell (open it as administrator).

Set-SPSite -Identity "<SiteCollection>" -SecondaryOwnerAlias "<User>"

If you got the same error so it's permission issue, try to check farm account user mapping for this database as the following permission

enter image description here

0

couple of things can cuase this issue, please make sure following.

  • Farm admin Account and App Pool account of the Web Application( where this db is attached) should have DBO rights on the restored db
  • Restored DB should be Online in the SQL Server( no read only)
  • Make sure no other content DB has the same site collection in it, attached to the farm.
  • make sure enough free space on the SQL Server
  • from central admin > upgrade and migration > review database status...on this page check what is the status of the DB.
0

I found the solution by my self. This is the fix: Set-SPSite -Identity http://spsite -UserAccountDirectoryPath ""

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .