I'm currently building document libraries for my team and am running into a privacy issue. I have created the library, broken permission inheritance, and added only the single group that needs access. However, everyone on my team (outside of that group) is still able to access the library and documents. I'm assuming that this is due to Limited Access permissions, but I cannot figure out how to resolve this. I did try to go into the Limited Access list and remove a specific user, but he is still able to view the material.

For some reason I'm unable to wrap my mind around this and would greatly appreciate any and all help I can get.


I am currently operating on SharePoint 2013 (not 365). Also, there are other libraries contained within this SharePoint site. Essentially, there is 1 main site, and 5 document libraries. Each document library is specific to a location and within each folder that's created, unique project members will be added to that folder...which I believe is creating the 'Limited Access'. However, I need to create a document library, break inheritance, and only allow a small # of people into the library due to very confidential information.

  • In the Broken Inheritance page have you removed all other groups & users? Also under the library advanced permission page just check the permission of a user and see what permission shows up. Commented Sep 1, 2016 at 22:45
  • I did, but the user I was testing still had limited access on his profile when I checked permissions. I'll have to dig deeper tomorrow, but your comment and Jordan's note - has me on the right path.
    – Luke
    Commented Sep 1, 2016 at 23:55
  • Hi Amal, I dug into your suggestion deeper. In this instance, I did remove all users, selected "check permissions" and entered a users name. They still populated with 'limited access'...IDK, it's pretty frustrating that even after removing specific permissions, and then limited access, users are still able to get into the library.
    – Luke
    Commented Sep 2, 2016 at 13:45
  • To find the root cause your best option is to keep removing that user from each group and check the permission page..hope you hit the jackpot soon (y) Commented Sep 2, 2016 at 13:52

2 Answers 2


Since you're the one that created the library and are able to adjust the permissions in the first place, are you and your team site collection owners? If so, that would supersede other permission assignments, meaning those users would always retain access to all content within that site collection (essentially, Full Control).

The other possibility would be user policies at the web application level. I haven't played with this much in O365, so I'm not sure if that's a thing or if I'm even using the correct terminology if it is, but that's another level where permissions could be allocated to users, such as IT, to override the granular permissions assigned within the sites themselves.

  • Jordan - I think you're absolutely right and if so, I'm going to rethink my entire existence. I'll circle back tomorrow. Thank you for your quick responses!
    – Luke
    Commented Sep 1, 2016 at 23:55

There is no web application level settings in SharePoint Online. All site collections run inside a single web application to which you have no config access.

More likely that when stopping permissions inheritance on the doc library the current site permissions have been copied to the library. This is default behavior. You need to remove these groups/people and specify the people who require access.

  • Hi Ian - I appreciate your note. I did some additional testing, highlighted below: I created the doc library, broke inheritance, gave myself full control permissions, and deleted all other permissions. It's still generating the alert that 'limited access' users can access the site and other team members are able to access it when I share the link with them.
    – Luke
    Commented Sep 2, 2016 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.