3

I have a test Sharepoint 2007 farm setup with its own domain on AWS. Recently I created a site and developed an InfoPath 2007 form for submitting data to multiple lists. This was all working great. Not sure this is relevant, but I changed the ports so I could access it from within my domain (the original port was blocked, so I changed to one that wouldn't be.) I don't think this is the issue as I changed the port back and tried updating my existing InfoPath form, but I get the same error message below (the first error.)

Now when I try to connect to the Sharepoint from a NEW InfoPath form to receive data I am prompted for credentials, but the credentials are not accepted and I get a failed connection. The error has been multiple different messages, the error I am getting now is:

Unable to connect to the Sharepoint site.

InfoPath either cannot connect to the data source or the service has timed out.

I am able to connect to this site with the same credentials via a browser. I also tried increasing the IPFS timeout, to no avail.

At first I thought that IPFS was turned off, but I can confirm it is enabled. When trying to configure IPFS, I was getting a registry error - which is now fixed. I am not sure IPFS was available in the admin console previously when everything was working, but it is now. I have also gotten the following error, but am not any longer:

The SOAP response indicates that an error occurred on the server: Exception of type 'Microsoft.SharePoint.SoapServer.SoapServerException' was thrown. The Web application at "..." could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.

Any help would be greatly appreciated. I am not experienced with this, learning as I go, so I am not sure where to start.

Thanks

EDIT: It seems I am able to make Web Service connections - at least the credentials are accepted and I get the available actions from Lists.asmx. Above I am referring to creating a simple Receive data connection to a Sharepoint list directly. I have tried using the full URL to the list and the base URL for the site - with the former I get an error that the hostname could not be determined from the URL and the latter I get the first error I posted.

  • Have you checked the existing data connections? In InfoPath, select Data tab > Data Connections. Review the connections and all the data source file stored online. Maybe the old port number is stored and you need to update it? Also the connection have different format between 2007, 2010, 2013. Are you using matching version InfoPath? – Mark L Aug 31 '16 at 2:11
  • I tried editing the forms to update the IP/port and creating a new form, both connections fail with the same error. I've also tried using the old port number on the server. – sjensen85 Aug 31 '16 at 2:52
0

After recreating the Sharepoint farm on another server and attempting to expose the service through port 80, it turns out the issue was with the Alternate Access Mappings. I am not exactly sure what the issue was, I believe I had tried the solution prior, but everything is working now. I changed the Internet zone to IP:PORT.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.