0

Here my issue: I have 2 SP farms, therefore two web apps/site collections/ etc.

On one, I run: Import-SPWeb -Identity "http://policies/locations/0015/" -Path "C:\filepath.cmp" -Force

which works just fine. On the other farm, I run basically the same with the exception of the identity: Import-SPWeb -Identity "http://v2policies/locations/0015/" -Path "C:\filepath.cmp" -Force

However this one gives the "Cannot find an SPWeb object with Id or Url" error.

Both URLs are valid, so why would one work and the other not? Running PS as admin, and the user account I am logged into is part of "SPShellAdmin". Running from CA server in each farm.

  • run get-spweb -identity v2policies/locations/0015 and share the out put and also what if you browse this in broswer v2policies/locations/0015 – Waqas Sarwar MVP Aug 30 '16 at 17:53
  • Running that gives the "Cannot find and SPWeb object with Id or URL" error. I am able to pull it up fine in the browser though. – grantjames Aug 30 '16 at 18:01
  • it ia subsite, Site collection, list or library? try wtih get-spsite – Waqas Sarwar MVP Aug 30 '16 at 18:02
  • Okay so running get-spsite returns the URL fine. So now what does that mean here? (Sorry, still fairly new to all this). – grantjames Aug 30 '16 at 18:07
  • Looks like you are trying to import subsite on the a Site collection...is it right? from where u export it, did you exported a subsite or site collection? – Waqas Sarwar MVP Aug 30 '16 at 18:11
0

Well I've gotten it to work now. It appears as if even though the account was in "SPShellAdmin" the content DB wasn't specified. Following the steps here: bramnuyts.be/2011/06/08/… seem to have fixed it up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.