0

I cannot get my Secure Store Service to work on my dev environment. I am trying to use a new external content type to render a SQL DB table in SharePoint (BDC).

When I visit Manage Service applications and Secure Store Service I am receiving the error:

Cannot complete this action as the Secure Store Shared Service is not responding.

  • The ribbon is greyed out.
  • I am logged in as the admin account

I have tried:

  • I stopped and started Secure Store Service
  • I stopped and started SecurityTokenServiceApplicationPool in IIS
  • I went to Administrative Tools – Local Security Policy and ensured admin account has Log on as a Service and I added the admin account to Log on as a batch job
  • I ran IISRESET (I rebooted the machine a few times over the course of the last 24 as well)

I checked the services:

  • Claims To windows Token Service is started
  • Secure Store Service is started
  • PerformancePoint Service is started

I checked BDC as well:

Central Admin - Application Management - Manage Service Applications – Business Data Connectivity Service. I checked my external content type and checked object permissions. All Authenticated Users was set with all permissions checked. I set object permissions for the admin account as well.

Finally, Windows Authentication enabled and ASP.NET Impersonation enabled in IIS. I checked the web.config and it matches.

I’m not sure what more to look at. Any ideas are greatly appreciated.

  • any correlation ID or anything is ULS logs or event logs? – Waqas Sarwar MVP Aug 30 '16 at 15:38
  • Nothing regarding secure store. It doesn't show any correlation ID at all. Of course I do get errors regarding the anonymous login. – Sean Aug 30 '16 at 15:50
  • Error from Application logs: the secure store service application is not accessible, The full exception of the text is: The socket connection was aborted. – Sean Sep 6 '16 at 20:37
1

Looks like issue with the SSL certs. You have to bind the correct cert with it.

  • first get the thumbprint of SharePoint Service Cert from the Cert store.
  • then delete the existing cert using this netsh http delete sslcert ipport=0.0.0:32844
  • now register the cert properly. netsh http add sslcert ipport=0.0.0:32844 certhash=<thumbprint> appid=<appid> certstorename=SharePoint

Read more here AND THIS

Also check this one:http://sensoft2000-sharepoint.blogspot.com/2010/10/error-security-token-service-is-not.html

  • +1 for the info. I had not seen all of these articles. Nonetheless, after attempting everything here, still no luck. – Sean Sep 8 '16 at 19:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.