4

What I want to achieve:

I want to use a custom page layout for a site in my Site Pages Library and therefore upload a Layout Page into the SharePoint Site via SharePoint Designer 2013.

My current status:

My site type is a Team Site, but I have the Publishing features on the site collection and in the site settings enabled.

What I have already tried:

I am trying to upload a layout page with SharePoint Designer on my Page Layout folder within my site. This steps seems to work, but after the upload is "finished" the specific file is not visible in the Designer like you can see here:

enter image description here

Does anyone know why SharePoint Designer is not showing this file? And yes, I have restarted the Designer already.

EDIT:

I have found the file in _catalogs -> masterpage, but when I try to open my site (which is connected to the layout page), it crashes with following error screen:

enter image description here

EDIT 2:

I have also checked my Layout and Template Site Settings and found that all layouts should be usable on my site:

enter image description here

But still I cannot view the page with this layout page.

  • 1
    Did you check in All files --> Catalogs-- > masterpage section? – Unnie Aug 30 '16 at 8:23
  • @Unnie yes the pages is visible in the masterpage folder and the my Site is also connected to this Layout Page but as soon as I try to open the Site it fails with an error message saying This page is not using a valid page layout. To correct the problem, edit page settings and select a valid page layout." – Snickbrack Aug 30 '16 at 8:35
  • go to site settings --> Under Look and Feel --> Page Layouts and site template settings--> check the configuration of Page Layouts. Check whether your custom page layout is allowed to be used. – Unnie Aug 30 '16 at 8:38
  • @Unnie have adapted my question – Snickbrack Aug 30 '16 at 8:41
  • Which content type is displayed besides your page layout name in _catalogs/masterpage section (list view)? – Dikesh Gandhi Sep 3 '16 at 7:53
4
+50

SHORT ANSWER


You need to associate the file to appropriate pagelayouts content types.


EXPLANATION


When you upload a file to master pages and pagelayouts gallery it is assigned to design file content type.

enter image description here

enter image description here

If you want the pagelayout to be visible under the pagelayouts option for a page, make sure to assign pagelayout content to the file being uploaded to the master page and pagelayouts gallery.

enter image description here

enter image description here

The file with properly content association will appear under pagelayouts options for a page in edit mode.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.