1

I have a SharePoint list and normally the 'three points' (item menu with the options View Item etc.) are always a column. I don't know why but this is not the case in my view/list. How can I change it? Thanks!

4

If you don't want to use Title column then you can add that menu to your another existing column also.

1.Open your View page( default AllItems.aspx) in designer(list and Libraries -> List_name -> Views -> AllItems.aspx).

  1. Now Look for FieldRef tag of your item to which you want to attach that menu.

  2. Now add ListItemMenu="TRUE" in that tag.

  3. Save youe page and its done.

5
  • Open List > From above ribbon at List tab > Select modify view

enter image description here

  • Make sure that this column ( Title (linked to item with edit menu) ) is selected at your view.

enter image description here

  • Thank you guys very much. I saw that the (linked to item with edit menu) is standing behind another column. I may accidentally changed it. How can I change it back? – Kim Aug 30 '16 at 13:29
  • How is it standing behind ? should you share any screen shot or elaborate more, please ? – Mohamed El-Qassas MVP Aug 30 '16 at 13:31
  • Sorry my English isn't perfect, thought it was clear. I have two columns (title and comment). How it should be: Title (linked to item with edit menu) | Comment How it looks like in my settings: Title | Comment (linked to item with edit menu) Hope you understand what I mean! – Kim Aug 31 '16 at 13:32
  • you need to merge both items to be one column and linked to edit item , or you need title linked to edit and comment linked to another page that is setting ? – Mohamed El-Qassas MVP Sep 2 '16 at 9:51
  • No, I just want the title to be linked to the edit item menu. The other column shouldn't be linked to anything. – Kim Sep 2 '16 at 13:51
4

Modify the view and make sure that the column called Title (with Edit Menu) is selected. This is the one that has the dropdown menu attached to it.

  • Thank you guys very much. I saw that the (linked to item with edit menu) is standing behind another column. I may accidentally changed it. How can I change it back? – Kim Aug 30 '16 at 13:29
  • I don't want you to have to double post each response. M.Qassas took the time to provide you a screenshot, so let's just continue in his answer thread below and upvote that. (I agree with his latest comment; we need to know what "standing behind another column" means. Provide a screenshot if you can, it's easier than trying to describe with words.) – NiceNix Aug 30 '16 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.