5

I am not able to open Word documents using Office Web Apps. When trying to open it I'm getting this error-

enter image description here

I have run ULS logs on OWA server.

ULS Logs-

WOPICheckFile,WACSERVER BadRequest [current url:http://server:43616/_vti_bin/wopi.ashx/files/678676d7d0b1410b866f089695bf2481?access_token=REDACTED_1050&access_token_ttl=1472504532529]

WOPI CheckFile: Catch-All Failure [exception:Microsoft.Office.Web.Common.EnvironmentAdapters.FileUnknownException: WOPI 400
at Microsoft.Office.Web.Apps.Common.WopiDocument.LogAndThrowWireException(HttpRequestAsyncResult result, HttpRequestAsyncException delayedException)
at Microsoft.Office.Web.Apps.Common.HttpRequestAsync.End()
at Microsoft.Office.Web.Apps.Common.WopiDocument.GetWopiRequestResultWithRetry(Int32 maxSize, MemoryStream ms, WopiRequest wopiRequest)
at Microsoft.Office.Web.Apps.Common.WopiDocument.CheckWopiFile()]

WOPI CheckFile: Catch-All Failure [url:http://server:43616/_vti_bin/wopi.ashx/files/678676d7d0b1410b866f089695bf2481]

  • Is it for SharePoint 2010 or 2013? – Benny Skogberg Aug 29 '16 at 11:57
  • It is SharePoint 2013 – Kamalpreet Aug 29 '16 at 12:05
  • Hi Kamalpreet, install latest service pack for OWA and then try. We were also facing similar kind if issue, installing latest service pack resolved that. – P S Aug 30 '16 at 5:17
1

I assume you're running Office Web Apps farm 2013 (which is very different from Office Web Apps 2010).

Run the PowerShell script Get-OfficeWebAppsMachine and see the output healthy/unhealthy

enter image description here

If it's healthy, you can see whether you allow HTTP or HTTPS requests to you OWA-farm by running

Get-SPWOPIZone

If you require HTTPS you can still test HTTP and see if there may be the SSL that's causing your problem. Set HTTP by running

Set-SPWOPIZone - zone "internal-http"

  • It is Healthy.. – Kamalpreet Aug 29 '16 at 12:07
  • @Kamalpreet Good. Do you allow HTTP or do you require HTTPS – Benny Skogberg Aug 29 '16 at 12:08
  • requires HTTPS.. – Kamalpreet Aug 29 '16 at 12:26
  • @Kamalpreet I've edited the answer. You could try running HTTP and see if that works. Then your problem is narrowed to SSL and possably the certificate and/or trust – Benny Skogberg Aug 29 '16 at 12:45
  • Now documents are opening in desktop application. We need to use OWA. – Kamalpreet Aug 29 '16 at 13:06
1

Another case is just encountered where it shows the same error but its due to a recent update by Microsoft.

A recent update in OWA 2013 created an issue with SharePoint 2013 where it do not work with the sites or the files path that have spaces in their URLs. For example,

OWA will work: http://webapplication/sites/subsite/WithoutSpace

OWA will not work: http://webapplication/sites/subsite/With Space

Microsoft has recently released its patch on April 11, 2017 for SharePoint on this issue. Apply below patch (be patience if you don't see anything happening on the screen for couple of minutes) on all SharePoint servers only (not OWA ones).

https://support.microsoft.com/en-us/help/3178732/april-11-2017-update-for-sharepoint-foundation-2013-kb3178732

Hope that will help someone.

Source: https://social.msdn.microsoft.com/Forums/office/en-US/bd7da9fb-eff7-418b-9263-c19b25c1b65c/office-web-apps-server-2013-march-2017-update?forum=sharepointadmin

0

I have solved this myself. The actual error was on the IIS website. It was set to redirect to https from http. Removing this setting worked in my case.

  • In my case status shows Unhealthy and i am using external-https, this online document feature was working fine before but now it giving error mentioned in the main question – Chetan Mar 18 at 8:14
0

I have clarification for the main question. When i changed My SharePoint server TLS 1.0 protocol to 0 , i got this document error issue as soon as i changed it to 1(Enabled TLS1.0) in registry settings it started to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.