0

I'm using SharePoint 2010 and installed VS 2012 and SQL Server 2008. I open PowerShell and run as administrator and also my account as farm admin. But I still can't running powershell SP script with error : The Local Farm is not accessible.

I already read from here : Powershell: cannot access the local farm

But when I tried to add Sharepoint_Shell_Access for my content & config database, it said "A possible cause of this error is that the account name was already added to the database as a login using a different user name than the account name" So I think my account already registered as database admin also, But why I still can't access my local farm from PowerShell??

Any idea guys?

0

Can you login to SQL Server and check if the account have following three roles on SharePoint_Config database?

  1. Pubic
  2. SharePoint_Shell_Access
  3. SPDataAccess

If no, Then can you try running the PowerShell command with SharePoint app pool account.

0

One possible solution can be

  1. Go to Central Administrator
  2. Select "Manage Web Application"
  3. Select web application in which your site collection resides
  4. Select "User Policy" from ribbon
  5. Select "Add Users" link
  6. There is alreay selected "All Zones"
  7. Then select "Next" button
  8. Add user in people picker and press enter to validate user you have entered and make sure it is validated
  9. Check "Full Control" checkbox and press "Finish" button

Comment if you have any query.

0

Thanks for all your help. It works now. I still have no idea why i can't access it yesterday. But suddenly it works today, I'm even changed nothing. Weird

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.