2

I have a local, on-premise dev installation of SharePoint 2013 standard edition.

I have created a new ContentSource to crawl a third party API. I can see it crawled APIs successfully. I can even search it with - /_api/search/query?querytext='some-text'

But I'm not able to get any result in Site search. What I know is that to get that Site search to work, we need to have result sources configured.

So my question is how to connect ContentSource with ResultSource? or I'm missing something here?

0
  • Go to Search Service Application in CA
  • Click “Result Sources” below Queries and Results.
  • Click “New Result Source”
  • in Query Transform section, click “Launch Query Builder”
  • build your query based on a specific Content Source. Check this to know how to build your query.

enter image description here

For more details check :

  • Thank you @M.Qassas. I created a Content Source for - api.github.com/users. Did a Full crawl. Created a 'Local SharePoint' result source as described above. But I do not get me any results. am I still missing something? – Codie Aug 28 '16 at 12:10
  • Have you already connected content source to result source but it's not worked ? also should you tell me if you don't use API service within content source are you face any issue ? – Mohamed El-Qassas MVP Aug 28 '16 at 12:18
  • It did not work. I created a ContentSource for crawling a normal website. Another ContentSource for crawling Github API. And created separate result sources with setting the Query Transform. But none of them worked - meaning - when I search from site search textbox, I get no search results. – Codie Aug 29 '16 at 3:37
  • Btw, I'm using SharePoint 2013 Standard Edition, will that be a cause of issues? – Codie Aug 29 '16 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.